Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Could not find a version that satisfies the requirement...
#1
Ya una vez lograda la odisea de subir el pyconio a PyPI, la trato de instalar en mi propio pc pero...
Código:
Could not find a version that satisfies the requirement pyconio (from versions: 1.0f)
No matching distribution found for pyconio
No le encuentro solución, y PyPI me esta volviendo loco, o soy el único que le pasa este error?
Responder
#2
¿Cuál es el contenido de tu archivo setup.py?
Responder
#3
Responder
#4
El problema es que no concuerda la versión que indicás en setup.py con la del nombre del archivo. Fijate que este comando efectivamente funciona:

Código:
python -m pip install pyconio==1.0fn
Responder
#5
(26-09-2018, 11:44 PM)Francisco escribió: El problema es que no concuerda la versión que indicás en setup.py con la del nombre del archivo. Fijate que este comando efectivamente funciona:

Código:
python -m pip install pyconio==1.0fn

Pero hacer eso es molesto, como se haría para que solo se tenga que colocar el nombre y no la versión, tal cual como los demas modulos de PyPI?
Responder
#6
Justamente, tenés que hacer coincidir la versión que indicás en la función setup() con la especificada en el archivo que subís a PyPI.
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)