Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema PyVST con plugins que trabajan en Float32
#1
Hola,

he estado haciendo pruebas con el tutorial de PyVST y parece que funciona todo bien con los ejemplos mostrados.
El problema que estoy teniendo es que el tutorial funciona con un plugin gratuito que trabaja con streams de audio en float64 y muchos de los plugins que tengo funcionan con float32.
Al cargar cualquiera de dichos plugins, el programa lanza un error:

Código:
Traceback (most recent call last):
  File "MainApp.py", line 814, in callback
    plugin.process([input_audio], [output_audio])
  File "build\bdist.win32\egg\pyvst\vstplugin.py", line 188, in process
    self.process_replacing(inputs, outputs)
  File "build\bdist.win32\egg\pyvst\vstplugin.py", line 178, in process_replacing
    self.__process_replacing(byref(self.__effect), float_input_pointers, float_output_pointers, len(inputs[0]))
WindowsError: exception: access violation reading 0x00000000
Press any key to continue . . .

Los plugins que he probado son:

ATKUniversalDelay
SanfordReverb32
Guitar Rig 5
AnalogDelay
AfterShockDelay

Y solo funciona con el primero, el único que trabaja en float64, el resto son a float32.
Por cierto, trabajo con Python 2.7 x32 y los plugins son todos 32bit.
No encuentro prácticamente nada de información acerca de PyVST en google y llevo poco en el mundo de Python.

Muchas gracias!!
Un saludo
Responder
#2
Hola Ruben. Pude reproducir tu error con el plugin SanfordReverb y lamentablemente no encontré nada fuera de lugar que pudiera causarlo. Me suena más a un problema del módulo que vale recordar está en un estado beta. Te puedo recomendar que crees un incidente en el proyecto de GitHub. Igualmente, por lo que ví SanfordReverb también incluye una versión de 64 bit con la que probablemente tengas más suerte (suponiendo que tienes un sistema y una distribución de Python x64).

Lamento no poder ayudarte más que eso. Si logro algún avance no dudo en avisarte.

Un saludo.
Responder
#3
(02-03-2016, 09:57 PM)Francisco escribió: Hola Ruben. Pude reproducir tu error con el plugin SanfordReverb y lamentablemente no encontré nada fuera de lugar que pudiera causarlo. Me suena más a un problema del módulo que vale recordar está en un estado beta. Te puedo recomendar que crees un incidente en el proyecto de GitHub. Igualmente, por lo que ví SanfordReverb también incluye una versión de 64 bit con la que probablemente tengas más suerte (suponiendo que tienes un sistema y una distribución de Python x64).

Lamento no poder ayudarte más que eso. Si logro algún avance no dudo en avisarte.

Un saludo.



Buenos días Francisco, he publicado el incidente en su pagina de github. Voy a seguir investigando y si encuentro algo te aviso yo también, no lo dudes. Muchas gracias por tomarte tu tiempo y probarlo. Un saludo!
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)