Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
necesito ayuda con unos errores en PyQt5
#1
hola, no se si de pronto me puedan ayudar con un codigo, donde realice un programa para hacer un mixer de 5 canales. me base en el codigo de un programador donde el video esta aca( https://www.youtube.com/watch?v=QK_-dmCr...C3%A1nCruz ). no he podido correrlo, ya que el video se basa en PyQt4 y yo tengo PyQt4. He corregido unos errores donde he encontrado una solucion pero la verdad es que esta muy complejo. De pronto si alguien este interesado, dejare el codigo en un txt, les agradezco su ayuda. Gracias


Archivos adjuntos
.txt   proyecto_mixer.txt (Tamaño: 34,88 KB / Descargas: 0)
Responder
#2
Hola, bienvenido.

Te recomiendo que instales Python 2.7 y PyQt 4 para correr el código. Hay algunos cambios importantes entre PyQt 4 y 5, por lo cual no es una tarea trivial portar el código.

¡Saludos!
Responder
#3
(27-04-2021, 12:50 PM)Francisco escribió: Hola, bienvenido.

Te recomiendo que instales Python 2.7 y PyQt 4 para correr el código. Hay algunos cambios importantes entre PyQt 4 y 5, por lo cual no es una tarea trivial portar el código.

¡Saludos!

Hola Francisco que pena, es que ya instale python 2.7, pero no he podido instalar PyQt4 ni la libreria de pyo. no se si depronto me puedas colaborar con eso. Ya que intento instalar la libreria con pip install pyo o pip install PyQt4 y me sale errror a veces en el pip o a veces en el install
Responder
#4
Hola, deberías poder instalar versiones anteriores de PyQt4 y pyo para Python 2.7 sin problemas. Podés pegar acá el error completo de pip a ver si damos con el problema.

Saludos
Responder
#5
(27-04-2021, 07:16 PM)Francisco escribió: Hola, deberías poder instalar versiones anteriores de PyQt4 y pyo para Python 2.7 sin problemas. Podés pegar acá el error completo de pip a ver si damos con el problema.

Saludos
pues básicamente me aparece ese error con la librería de PyQt4 :

ImportError: No module named PyQt4

igualmente con la librería de pyo : 
                                                                                 
ImportError: No module named pyo

les agradezco la ayuda muchachos.
Responder
#6
(27-04-2021, 08:27 PM)diegop3101 escribió:
(27-04-2021, 07:16 PM)Francisco escribió: Hola, deberías poder instalar versiones anteriores de PyQt4 y pyo para Python 2.7 sin problemas. Podés pegar acá el error completo de pip a ver si damos con el problema.

Saludos
pues básicamente me aparece ese error con la librería de PyQt4 :

ImportError: No module named PyQt4

igualmente con la librería de pyo : 
                                                                                 
ImportError: No module named pyo

les agradezco la ayuda muchachos.

el error que me aparece en el cmd es:
pip install pyo
"pip" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
Responder
#7
Hola, ¿qué sistema operativo estás usando? Podés probar también con:

Código:
python -m pip install pyo
Responder
#8
(28-04-2021, 01:02 AM)Francisco escribió: Hola, ¿qué sistema operativo estás usando? Podés probar también con:

Código:
python -m pip install pyo

hola francisco, yo trabajo en windows.... cuando fui a poner este codigo, trato de instalar, pero me aparece un erro al final.
digamos en el caso de PyQt4 me aparece:
 Could not find a version that satisfies the requirement PyQt4 (from versions: none)
ERROR: No matching distribution found for PyQt4

y para el paso de pyo me aparece:
ERROR: Command errored out with exit status 1:
    command: 'C:\Users\juand\anaconda3\envs\python2\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'c:\\users\\juand\\appdata\\local\\temp\\pip-install-pl5fom\\pyo\\setup.py'"'"'; __file__='"'"'c:\\users\\juand\\appdata\\local\\temp\\pip-install-pl5fom\\pyo\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base pip-egg-info
        cwd: c:\users\juand\appdata\local\temp\pip-install-pl5fom\pyo\
    Complete output (5 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "c:\users\juand\appdata\local\temp\pip-install-pl5fom\pyo\setup.py", line 215, in <module>
        [os.path.join(data_files_common_path, f) for f in os.listdir(data_files_common_path) if f.endswith(".dll")])]
    WindowsError: [Error 3] El sistema no puede encontrar la ruta especificada: 'win64dlls\\win64_pyo_data_files_common\\*.*'
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
Responder
#9
Hola. El problema es que si tenés dos versiones de Python, tenés que asegurarte de que estés usando el pip de Python 2.7 y no de 3.8. Fijate ejecutando este comando en la consola qué version te informa:

Código:
python --version

Si no te dice Python 2.7, tenés que buscar la ruta donde se haya instalado esa versión, que en Windows típicamente es C:\Python27. En ese caso podés hacer:

Código:
C:\python27\python -m pip install pyo

Si seguís con problemas con PyQt4, podés descargar la versión precompilada desde acá: https://www.lfd.uci.edu/~gohlke/pythonlibs/#pyqt4. Y luego ejecutar:

Código:
C:\python27\python -m pip install PyQt4‑4.11.4‑cp27‑cp27m‑win_amd64.whl

(En caso de que hayas bajado el archivo para Python de 64 bit).

Saludos
Responder
#10
(28-04-2021, 06:55 PM)Francisco escribió: Hola. El problema es que si tenés dos versiones de Python, tenés que asegurarte de que estés usando el pip de Python 2.7 y no de 3.8. Fijate ejecutando este comando en la consola qué version te informa:

Código:
python --version

Si no te dice Python 2.7, tenés que buscar la ruta donde se haya instalado esa versión, que en Windows típicamente es C:\Python27. En ese caso podés hacer:

Código:
C:\python27\python -m pip install pyo

Si seguís con problemas con PyQt4, podés descargar la versión precompilada desde acá: https://www.lfd.uci.edu/~gohlke/pythonlibs/#pyqt4. Y luego ejecutar:

Código:
C:\python27\python -m pip install PyQt4‑4.11.4‑cp27‑cp27m‑win_amd64.whl

(En caso de que hayas bajado el archivo para Python de 64 bit).

Saludos
Bro que pena, lo intente en el cmd donde esta python 2 y no me sigue dando error, pero gracias, creo que no se puede. Gracias francisco por tu ayuda. Voy a intentarlo pasar al PyQt5
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)