Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Cambiar codigo de pseint a python
#1
Buenas noches

Tengo un codigo programado en pseint pero me gustaria poder pasarlo a python pero, no conozco este programa es para una tarea y no se que funciones deba usar Sad

Este es el codigo


Código:
    Escribir "Menu de operaciones";
    Escribir "1.- Suma";
    Escribir "2.- Resta";
    Escribir "3.- Producto";
    Escribir "4.- Division";
    Escribir "Indique operacion";
    leer op;
    
    //Lectura de numeros
    Escribir "Escribe primer valor";
    leer valor1;
    Escribir "Escribe segundo valor";
    leer valor2;
    segun op hacer
        1:
            resultado=valor1+valor2;
        2:
            resultado=valor1-valor2;
        3:
            resultado=valor1*valor2;
        4:
            resultado=valor1/valor2;
        De Otro Modo:
            Escribir "Operacion desconocida";
    FinSegun
    Escribir "Resultado = ", resultado;
FinAlgoritmo

Espero me puedan ayudar.
Muchas gracias
Responder
#2
Hola, bienvenido.

Te recomiendo que leas este tutorial de Python y en seguida podrás migrar el código vos mismo: https://tutorial.recursospython.com/.

Saludos
Responder
#3
Me sirvio mucho la guia muchas gracias.

Este fue el resultado del codigo pasado a python Big Grin

Código:
print("Menu de operaciones")
print("1.- Suma")
print("2.- Resta")
print("3.- Multiplicacion")
print("4.- Division")

op = int(input("Indique la operacion: "))

valor1 = int(input("Escribe primer valor:"))
valor2 = int(input("Escribe segundo valor:"))

if op == 1:
    resultado: int = valor1+valor2
if op == 2:
    resultado: int = valor1-valor2
if op == 3:
    resultado: int = valor1*valor2
if op == 4:
    resultado: int = valor1/valor2
if op < 1 or op > 4:
    print("Operacion desconocida")

print("Resultado =", resultado)

Pude hacer otro tambien gracias a la guia pero ahorita estoy teniendo problema con otro codigo.
Es este:
Código:
Algoritmo Regreesion_lineal_multiple
    Dimension datosx[200],datosy[200]
    Escribir "Ingresar la cantidad de datos n: =9 (de 2 a 200):"
    leer n
    
    para i <- 1 hasta n Hacer
        Escribir "Ingrese el valor de x[",i,"]"
        leer datosx[i]
        Escribir "Ingrese el valor de y[",i,"]"
        leer datosy[i]
        sumax=sumax+datosx[i]
        sumay=sumay+datosy[i]
        sumaxx=sumaxx+datosx[i]*datosx[i]
        sumaxy=sumaxy+datosx[i]*datosy[i]
        
        
        
    FinPara
    a0=(sumaxx*sumay-sumax*sumaxy)/(n*sumaxx-sumax*sumax)
    a1=(n*sumaxy-sumax*sumay)/(n*sumaxx-sumax*sumax)
    Escribir "Ingrese el valor de x"
    leer x
    fdex=a0+a1*x
    Escribir "El valor de a0:=", a0
    Escribir "El valor de a1:=", a1
    Escribir "regresion f(",x,"):=", fdex
    
    
    
    
FinAlgoritmo

La funcion que estoy intentando usar es la de "Dimension datosx[200],datosy[200] " y la de "para i <- 1 hasta n Hacer"

que deberia de usar en este caso?
Responder
#4
Hola.

En cuanto al "para i <- 1 hasta n Hacer" en Python deberías usar un bucle for así:

  1. for i in range(1, n):


Para datosx[200], en Python el tipo de dato equivalente sería la lista. Las listas no tienen una cantidad de elementos predefinida, así que simplemente deberías inicializar las dos listas y luego agregar los elementos con append().

  1. datosx = []
  2. datosy = []


Sobre las listas te dejo esta guía: https://recursospython.com/guias-y-manua...-y-tuplas/.

Saludos
Responder
#5
Buenas noches
Estoy teniendo problemas con el codigo, esto es lo que llevo


Código:
datosx = []
datosy = []

datosx.append([200])
datosy.append([200])
n = int(input("Ingresar la cantidad de datos: = 9 (de 2 a 200)"))

for i in range(1, n):

    datosx[i] = int(input("Ingrese el valor de x[i]"))
    datosy[i] = int(input("Ingrese el valor de y[i]"))
Despues de ahi quiero hacer la prueba para que me deje introducir los 9 numeros en datosx y datosy pero despues de ingresar la cantidad de 'n' al querer poner los datosx[i] me salta error Sad
Responder
#6
Sería más bien así:

  1. datosx = []
  2. datosy = []
  3.  
  4. n = int(input("Ingresar la cantidad de datos: = 9 (de 2 a 200)"))
  5.  
  6. for i in range(n):
  7.  
  8. datosx.append(int(input("Ingrese el valor de x[i]")))
  9. datosy.append(int(input("Ingrese el valor de y[i]")))
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)